avatar

目录
华为交换机划分Vlan和添加Vlanif以及设置端口的方式

简言

这里领导搭建公司的两地(延申集群),需要对核心交换机进行配置,特此总结一下。

需求如下

浦江vlan:
Vsphere集群管理网络:192.170.8.0/24 vlan2110
Vsan网络:192.170.9.0/24 vlan2120 #添加interface XGigabitEthernet2/0/6 和7(access)
VM网络:192.170.10.0/24 vlan2130 #添加interface XGigabitEthernet2/0/11和12(trunk)

划分Vlan

VLAN(Virtual Local Area Network),即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以通信,而不同VLAN间不能通信,从而将广播报文限制在一个VLAN内。

进入交换机界面输入sy,进入[]模式

图一

创建vlan

直接输入vlan 数字即可,这里我们可以使用dis this来查看vlan的详细信息。

[Quidway]vlan 2

批量创建vlan的方法

vlan batch 10 20

添加Vlanif

这里介绍下Vlanif,vlan间互相通信可以通过vlanif接口来实现,也可以通过路由器的子接口来实现。

vlanif即三层接口是一个虚拟口,可以配置IP地址,vlan是一个二层vlan标示相当于对数据打标签,vlan对应vlanif接口。

配置vlan IP

[Quidway]interface Vlanif 2

配置vlanif ip地址

[Quidway]interface Vlanif 2

[Quidway-Vlanif2]ip address 10.10.100.1 255.255.255.0

配置完成之后即可输入dis this查看配置内容

端口配置

进入端口配置(access)

int g/0/0/1 #进入以太网接口0/0/1

int xg/0/0/2#进入万兆以太网接口0/0/2

port link-type access 设置端口为access模式

port default vlan 10 将端口放入vlan10

进入端口配置(trunk)

int g/0/0/1

int xg/0/0/1(前面+x为万兆)

port link-type trunk 设置端口为trunk模式

port trunk allow-pass vlan all 设置为允许所有vlan的报文通过

port trunk allow-pass vlan 10 20 runk口允许通过的VLAN

Access类型的接口用来连接用户主机,它主要用于接入链路,且接入链路上通过的帧为不带Tag的以太网帧。如果Access接口配置了缺省VLAN,则在该报文上加上Tag标记,并将Tag中的VID字段的值设置为接口所属的缺省VLAN编号,此时接入链路上允许与缺省VLAN Tag匹配的以太网帧通过。

Trunk类型的接口用来连接其它交换机设备,它主要连接干道链路。Trunk接口允许多个VLAN的帧通过。

删除端口的配置

undo port link-type 删除端口的配置

删除vlan的配置

undo vlan

undo vlanif

批量将端口划入vlan

注意:端口划入vlan前需将其设置为access模式

[1]port-group 1 建立分组并命名为1

[1-port-group-1]group-member g0/0/1 to g0/0/10 将g0/0/1 到10的端口加入到1分组中

[1-port-group-1]port link-type access 将端口类型均设置为access

[1-port-group-1]port default vlan 10 将1分组及组内端口划入vlan10

文章作者: 刘向洋
文章链接: https://liuxiangyang.space/2019/09/08/00023/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 LXY`S BLOG
打赏
  • 微信
    微信
  • 支付宝
    支付宝

评论
广告